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1 Introduction 
In the realm of astrophotography it’s a fairly safe bet to state that there are more LRGB image 

processing tools than you can shake a stick at, and everybody has their own favourite processing 

procedures that they follow.  

I make no bold claims for the procedure that I detail in this document except to say that over the 

years I have tried a lot of software packages and procedures and this document is a distillation of 

those and the procedure that I have settled on when processing my LRGB images.  

These procedures are for processing LRGB DSO (Deep Sky Objects) and cannot of course be made to 

be 100% generic for all types of DSO and exposure circumstances, they do however provide a solid 

platform upon which you can launch into the realm of LRGB processing. 

The software tools that I use are as follows: 

• Atik’s Dawn on the captured FITS files (I capture my images via an Atik CCD and have found 

their capture and processing software to be simple to use, effective and bug free); 

• FitsLiberator to produce 16-bit TIFF files from the FITS files; 

• Photoshop for the main processing on the TIFF files including the use of the following 

Photoshop plugins: 

o gradiantXterminaor (https://www.rc-astro.com/resources/GradientXTerminator); 

o WhiteCal (https://www.deepskycolors.com); 

o Hasta La Vista Green HLVG (https://www.deepskycolors.com); 

o Astronomy Tools 

(https://www.prodigitalsoftware.com/AstronomyToolsActions.html). 

 

 

The basic outline of my image processing procedure is: 

• Use Atik’s Dawn software to produce master bias, dark and flat FITS files; 

• Use Atik’s Dawn software to apply the master flats and dark to the light (L, R, G and B) 

images, align and stack into individual L, R, G and B FITS files; 

• Use FitsLiberator on the stacked L, R, G and B FITS files to apply some pre-processing and 

save them as TIFF files; 

• Use photoshop on the L, R, G and B TIFF files to process the images and combine them into a 

single LRGB image. Save as TIFF and JPEG. 

 

This article and others can be found on my website www.astroworkbench.co.uk. 
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2 Produce master Bias, Darks and Flats 
Set my separate document LRGB imaging setup and acquisition for how to capture sets of bias, 

darks, flats and lights. The notes below detail how to process these images once acquired. 

I use Atik’s Dawn software, which is the software shown in the screen shots below, but the 

processing principles are the same if using different processing software. 

2.1 Bias 
A master bias only has to be produced once. 

Combine all bias frames into a single master bias. Ensure that all alignment options are switched off 

in your software (i.e. only stack, do not align). This master bias will only be used in the flat frames. 

 

 
 

Figure 1 - Produce Master Bias (Atik Dawn) 

 

2.2 Darks 
A master dark for each combination of exposure time and CCD temperature must be produced, but 

only needs to be done once. 

Combine all dark frames into a single master dark. Ensure that all alignment options are switched off 

in your software (i.e. only combine/stack, do not align).  

 

 
 

Figure 2 - Produce Master Dark (Atik Dawn) 

You do not have to apply any bias frames as bias is already intrinsically present in the dark frames by 

the action of capturing the darks. 
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2.3 Flats 
A set of flats is required for each filter and CCD temperature combination for each observing run 

unless your imaging equipment orientation is never changed, but even then additional dust may be 

introduced between observing runs requiring new flats. 

1) The bias master must be subtracted from every flat frame. Hence the flat frames must be 

processed as light frames with the master bias subtracted from each. 

2) Combine the bias corrected flat frames into a single master flat for each of the four filters 

(LRGB). Ensure that all alignment options are switched off in your software (i.e. only stack, do 

not align).  

3) You will now have four master flat frames (e.g. master flat L.fit,  master flat R.fit, master flat 

G.fit, flat and master flat B.fit). 

 

 

  
Figure 3 - Produce Master Flats (Atik Dawn) 
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3 Process LRGB Lights 

3.1 Using Atik’s Dawn software to apply master dark and flats images to LRGB lights 
• Load the Monochrome 3 template (shown below); 

• For each set of L, R, G and B light images we must: 

 

o Apply master dark to each light frame; 

o Apply the correct master flat for the appropriate filter to each filtered light frame set 

(divide); 

o Do not apply any bias master as this was incorporated previously to the master flat; 

o Align and combine/stack. 

 

 

Figure 4 - Apply Master frame Corrections (Atik Dawn) 

After performing the above sequence flow for each set of the L, R, G and B Light image sets (the 

master dark will be the same for each, but the master flat will be different for each) you will 

have four files: A dark corrected, flat corrected, stacked and aligned image for L, R, G and B (e.g. 

M81-L-combined.fit, M81-R-combined.fit, M81-G-combined.fit, M81-B-combined.fit). 
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3.2 Process in Fits Liberator to get TIFF files 
 

 

Figure 5 - FitsLiberator 

 

1. Use Fits Liberator on each of the L, R, G and B combined files from the step above (e.g. M81-

L-combined.fit, M81-R-combined.fit, M81-G-combined.fit, M81-B-combined.fit) to process 

them and save as a TIFF: 

 

• Open each file in FitsLiberator; 

• Ensure the Channels radio button it is set to 16 bit; 

• Set the histogram white and black level sliders; 

• Click on the Auto scaling button; 

• Use arcSinh(x) as a first attempt but experiment with the others; 

• If the image is too dark, increase the Scaled Peak Level to higher values (e.g. 

100, 1000). 

• Use the Save File to save the image as a TIFF. 

 

 

2. You now have 4 TIFF files (e.g. M81-L-combined.tif, M81-R-combined.tif, M81-G-

combined.tif, M81-B-combined.tif). 
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3.3 Process TIFF files in Photoshop 
These instructions include the use of four photoshop plugins that I have found to be of significant 

help: 

• gradiantXterminaor (https://www.rc-astro.com/resources/GradientXTerminator); 

• WhiteCal (https://www.deepskycolors.com); 

• Hasta La Vista Green HLVG (https://www.deepskycolors.com); 

• Astronomy Tools (https://www.prodigitalsoftware.com/AstronomyToolsActions.html). 

 

1. Open all 4 TIFF images (L,R,G,B) in Photoshop. 

 

2. For each of the L, R, G, B images select Image->mode and: 

• Change to 16-bit which will auto display the HDR toning screen. If already 16-bit then 

open image->adjustments->HDR Toning; 

• Try the two settings: Local Adaptation and Exposure and Gamma, depending upon the 

object and exposure decide which one reveals the best detail (do not worry about any 

gradient and other image issues at this point as they will be removed later); 

 

3. For the L image use gradiantXterminaor to remove any gradients as follows: 

• With our luminance channel open, select the Lasso Tool from the toolbar and draw 

around the DSO, being careful not to clip the DSO; 

• Inverse the selection, Select > Inverse; 

• Open GradientXTerminator. Set the Detail to Medium and Aggressiveness to Low or 

Medium. Click OK; 

 

Figure 6 - GradiantXterminator 

• This has applied a mild gradient reduction to the image. Now we can home in and apply 

a more aggressive gradient removal; 

• Select the Magic Wand Tool from the toolbar and set a tolerance of around 8. Then click 

on the background of the image to select it. You may need to increase the tolerance if 

no selection is made. 

• Now re-select the Lasso Tool and whilst holding the alt key, draw once again around the 

DSO, to remove it from the selection: 

• Now re-open GradientXTerminator and apply another gradient removal with Detail set 

to Fine and Aggressiveness set to High. All gradients should now have been removed 

from the image. It may now be necessary to adjust the brightness of the image using the 

Levels tool. 
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4. Repeat the above GradiantXterminaor process for your R, G and B images. 

 

5. If any obvious gradient/light pollution remains on any of L, R, G, B: 

 

• Use the Astronomy Tools Plugin utility Light Pollution Enhanced flatten and on the first 

window popup increase the Dust and scratched radius, and on the 2nd window popup 

leave the threshold and drag down the curves. 

 

• If just the background around a DSO needs gradient/light pollution processing select the 

DSO with the Lasso tool and make it a separate layer via Layer->New->Layer Via Cut, 

then just apply the Light Pollution Enhanced flatten to the background layer, then alter 

levels on the new DSO layer to equalise and then merge both layers. 

 

6. On Luminance image only select Image->Adjustments->Curves: 

 

• Enhance the faint data in just the DSO without blowing out the stars or the DSO core by 

making multiple anchor points on the curve by using ctrl-click on the black background, a 

star, the inner galaxy region and the arms. This will give you four anchor points on the 

curve. Now just adjust the anchor point for the galaxy arms of the galaxy to bring out the 

details. 

 

• Use image->adjustments->levels and adjust the first and middle sliders only to make the 

background dark and bring out detail of the object. Repeat curves and levels iterations (L 

image only) as required until you are pleased with the enhancements. 

 

 

7. Repeat all of the above step on the R, G and B images. 

 

8. Run the Astronomy tools deep space noise reduction on all L,R,G and B images. 

 

9. Use the Astro tools plugin to run Local Contrast enhancement on the luminance image. 

 

10. Luminance layer Unsharp Mask for DSO objects. 

• To just sharpen the Luminance layer of a DSO and not the stars (which can cause 

unsightly artefacts around the stars) duplicate the background layer (right click 

Background layer and select Duplicate). On the duplicate layer use the Astronomy tools 

Select Brighter Stars. This may also select parts of the DSO in which case use the Lasso 

tool to select the DSO while holding down the alt key and it will be excluded from the 

selection. 

 

• Now Select > Modify > Expand and try a starter value of about 5 pixels.  

• Now Select > Modify > Feather and try a starter value of about 5 pixels. 

• Now use Ctrl X to delete the stars from the duplicate layer.  
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• Now  Filter > Sharpen > Unsharp Mask and try varies values until a pleasing 

enhancement of the DSO is obtained. 

• Flatten the L image, you should now see that just the DSO has been enhanced and the 

stars have not been altered. 

 

11. Luminance star size reduction 

o On the Luminance layer use the Astronomy Tools Action Make Stars Smaller. You 

can use multiple iterations but be careful not to over apply otherwise you will lose 

faint stars and processing artefacts will start to appear. 

 

 

12. Combine R,G and B channels: 

 

• Select the L image and select all, copy and create new image by ctl-A, ctl-C, ctl-N in the 

new image window that comes up set the Name to Object- RGB and the colour mode to 

RGB colour.  

 

 

Figure 7 - A new empty RGB image (photoshop) 

 

 

 

• On the new layer cloik on the channels tab and notice that it has RGB, Red, Green and 

Blue channels. 
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Figure 8 - RGB channels - empty (photoshop) 

 

• Paste the R, G and B images into the R,G and B channels of the new image (ctl-A, ctl-C 

and ctl-v on the new documents selected channel) so that it now looks like the following. 

The RGB channel auto shows the combined R,G,B just pasted in. 

 

 

Figure 9 - RGB channels populated (photoshop) 

• If the images in the separate R,G and B channels are out of alignment perform multiple 

iterations of making only two of the three channels visible so that you can see the stars 

in both visible channels superimposed on top of each other. Click the visibility on/off 

quickly on one of the two visible channels (i.e. a perform a blink comparison) so that any 

misalignment shows up. Select the move tool, and move the channel (via mouse or 

arrow keys) until it lines up with the other one on a very high zoom. Repeat for the third 

layer until all three are aligned.. 

 

13. Select the RGB channel, and If the colour balance looks a bit off, try the WhiteCal plugin to 

correct the RGB colour balance: 

• Select either a G2V star using the lasso or magic wand tool or just a part of your image 

that you assume should be white (e.g. a star or a galaxy centre). 

• Run the WhiteCal plugin and apply to the image. You may have to undo, reselect and 

run it a few times until a pleasing colour balance is obtained; 

 

14. Use Hasta La Vista Green (HLVG) plugin to remove any green colour cast: 

• This works on the basis that a green colour only appears in some planetary nebula, 

unless you are certain that a green colour should be present in your image, run the 

HLVG plugin (the Strong option will remove all green, medium about half and weak just 

a slight amount) to remove unwanted green colour; 

 

15. Add a Luminosity layer to your RGB image. 
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• On your RGB image, click on the Layers tab and then the Background layer, then go to 

the original L image and ctl-A, ctl-C and paste it on the new RGB image Background layer 

which will give a 2nd layer (called Layer 1); 

•  Change the layer’s type to Luminosity and rename it to Luminance Layer; 

•  Change opacity until the sharp detail of the L layer shows through but doesn’t swamp 

out the RGB information – usually around 50% is a good start. 

• If the Luminosity layer is out of alignment select and move it on a high zoom until the 

stars overlap. 

 

 

Figure 10 - New Luminosity Layer (photoshop) 

 

• At this point you now have the Background layer as your RGB image and the you also 

have your luminance image as a separate layer. 

 

16. Remove colour noise from RGB Background layer 

• If you have any residual colour blotches try the Astronomy Tools Colour Blotch Reduction 

 

17. Further correct colour balance on RGB background layer. If the previous steps have not 

resulted in a visually pleasing there are some other methods that can also be tried at this 

point which may (or may not) help: 

 

• Adjust the levels of each individual colour channel, or 

•  Image > Adjustments > Colour Balance and adjust the individual midtones channels until 

they all align on the histogram 

 

Figure 11 - Colour balance (photoshop) 
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Figure 12 - RGB histograms 

 

 

18. Increase RGB vibrance and saturation 

• Use the Image > Adjustments > Vibrance to increase the vibrance and saturation of the 

RGB image.  

 

19. Apply Gaussian blur to RGB background layer 

• Because the RGB does not contribute much to the fine detail in the final image (this 

comes from the luminance layer), you can try a mild Gaussian blur to remove noise. Use 

Filter > Blur > Gaussian Blur and try a radius of 1-2 pixels to see if this enhances your 

image. 

 

 

20. This is the final eyeball of your image, if not entirely happy then: 

• Run Another mild unsharp mask on the Luminosity layer only; 

• Make any finishing touches on curves, levels and colour balance. 

 

21. Flatten image (i.e. flatten the L and RGB layers to one final image). 

 

22. At this point save your image and you could try one final astronomy tools Enhance DSO and 

reduce stars but it may be too much so prepare to revert to the saved image. 

 

23. That’s it – crop as necessary and save your final image. You may also wish to also perform a 

Save As JPG at a suitable compression for easy sharing and publishing etc. 
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4 Example LRGB component and final images 
This section shows examples of the different types of images discussed in this document. This 

example is the M27 Dumbbell Nebula which is a favourite DSO of mine and a great object to try out 

your processing on as it responds really well to LRGB imaging. 

See my document LRGB Imaging Setup and Acquisition available on my website 

www.astroworkbench.co.uk for a full description of how to capture each type of image.  

 

4.1 Master Bias 
The figure below shows a master bias. These are used to compensate for any electronic noise 

present in any CCD (or CMOS) chip. They are dark (i.e. the cameras shutter is closed or scope is 

covered) and captured using the same temperature as your light images and the fastest speed, as 

close to 0 as possible, that the camera supports. You only need one master bias for each 

temperature that you use for light frame capture. 

 

Figure 13 - Master Bias 

 

  

http://www.astroworkbench.co.uk/
http://www.astroworkbench.co.uk/


www.astroworkbench.co.uk Processing LRGB Images     Page 15 of 19 
 

4.2 Master Dark 
The figure below shows a master dark, these images are used to compensate for hot pixels and are 

dark (i.e. the cameras shutter is closed or scope is covered) and captured using the same 

temperature and imaging time as your lights. Some CCD’s have so few hot pixels (or amp glow) that 

you can get away without darks.  

It looks very much like the master bias above except for the addition of the hot pixels. 

You only need one master dark for each temperature and exposure time that you use for light frame 

capture. 

 

Figure 14 - Master Dark 
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4.3 Master Flat 
The figure below shows a master flat for luminance images, it has been much enhanced for display 

purposes so as to clearly show typical image artifacts that flats are used to remove from the light 

images, in this case dust bunnies that appear as faint halos, corner vignetting from 1.25” filters that 

are right on the limit for the size of my Atik 383L+ CCD and the shadow caused by the pick off mirror 

in my Celestron OAG in a f6.3 image configuration. 

 

Figure 15 - Luminance Master Flat enhanced for display purposes 

 

In the individual LRGB images shown below you can clearly see the vignetting and OAG shadows 

which are removed via this flat master frame during processing. 

You will typically obtain a master flat for each filter used after every nights imagining session and is a 

little more involved that the capture of the other compensation masters above, see my document 

LRGB Imaging Setup and Acquisition available on my website www.astroworkbench.co.uk for a full 

description of how to capture flats.  
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4.4 A single L image 
The image below is one luminance image, many would be taken and then have the master 

compensation frames applied to each and then aligned, stacked and processed as described in this 

document.  

 

Figure 16 - A single raw L image 

 

4.5 A single R image 
The image below is one red image, many would be taken and then have the master compensation 

frames applied to each and then aligned, stacked and processed as described in this document.  

 

Figure 17 - A single raw R image 

 

  

http://www.astroworkbench.co.uk/


www.astroworkbench.co.uk Processing LRGB Images     Page 18 of 19 
 

4.6 A single G image 
The image below is one green image, many would be taken and then have the master compensation 

frames applied to each and then aligned, stacked and processed as described in this document.  

 

Figure 18 - A single raw G image 

4.7 A single B image 
The image below is one blue image, many would be taken and then have the master compensation 

frames applied to each and then aligned, stacked and processed as described in this document.  

 

 

Figure 19 - A single raw B image 
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4.8 Final LRGB image 
The image below shows the final result of utilising the image types described above and processed 

as described in this document. 

 

 

Figure 20 - Final LRGB image 
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